Revert "Add user with legacy hash ($2a…) instead of current hash ($2b…) for OpenBSD versions older than 5.7"
continuous-integration/drone/push Build is failing Details

This reverts commit 4012a014ce.
Versions older than 5.7 are … old.
We do not handle versions that old.
pull/37/head
Jérémy Dubois 2 years ago
parent a26d6e13cb
commit 6613c70446

@ -5,20 +5,6 @@
name: "{{ user.name }}"
gid: "{{ user.uid }}"
- name: "User '{{ user.name }}' is present with legacy hash"
user:
state: present
name: '{{ user.name }}'
uid: '{{ user.uid }}'
password: "{{ user.password_hash_openbsd_legacy }}"
group: "{{ user.name }}"
groups: wheel
shell: /bin/ksh
append: true
when: ansible_distribution_version is version_compare("5.7",'<')
tags:
- admin
- name: "User '{{ user.name }}' is present"
user:
state: present
@ -29,7 +15,6 @@
groups: wheel
shell: /bin/ksh
append: true
when: ansible_distribution_version is version_compare("5.7",'>=')
tags:
- admin

Loading…
Cancel
Save