Browse Source

Update NodeJS minimum version

master
Jérémy Lecour 5 months ago
parent
commit
1389cb96d6
2 changed files with 4 additions and 3 deletions
  1. +2
    -1
      .travis.yml
  2. +2
    -2
      INSTALL.md

+ 2
- 1
.travis.yml View File

@ -8,12 +8,13 @@ rvm:
### cf. https://github.com/Evolix/chexpire/pull/104
- 2.5
- 2.6
- 2.7
cache:
- bundler
- yarn
node_js: 9
node_js: 12
sudo: required # required with chrome addon
addons:


+ 2
- 2
INSTALL.md View File

@ -4,11 +4,11 @@
Chexpire requires :
* Ruby > 2.5.4 and Bundler
* NodeJS and Yarn
* NodeJS >= 10.13 and Yarn
* MySQL or MariaDB
We are usually running Chexpire on typical POSIX servers like :
- Linux Debian 9, Ruby 2.5.4, NodeJS 8.11 and MariaDB 10.1
- Linux Debian 9, Ruby 2.5.4, NodeJS 10.13 and MariaDB 10.1
- macOS High Sierra, Ruby 2.5.4, NodeJS 10.2.1 and MariaDB 10.2
It probably works on any system that supports Ruby >= 2.5.4, NodeJS >= 6 and MySQL >= 5.5. Feel free to report any unexpected incompatibilities.


Loading…
Cancel
Save